fuel pump

4.6L Modular 4 valve engine and 4.6L Modular 2 valve engine
Post Reply
chris01cobra
Private
Private
Posts: 4
Joined: Mon Jan 21, 2013 8:26 pm

fuel pump

Post by chris01cobra » Thu May 21, 2015 12:45 pm

Hey I have installed a 255 lph fuel pump. It idles fine in the range of 14.8 AFR but at WOT this 9.8 AFR.. I am not running boost just yet. Im not sure in Delta Force with the settings should be or even how to cut the volume of fuel back. I have the ultimate ford efi tuning guide book there is just not enough information on how to do this. I dont see the fuel pump voltage table or voltages in settings delta force. Maybe it's just worded different.
Right now I am running 24 pound injectors with a 24 air mass meter. Any help would be appreciated.
Last edited by chris01cobra on Thu May 21, 2015 2:32 pm, edited 1 time in total.

chris01cobra
Private
Private
Posts: 4
Joined: Mon Jan 21, 2013 8:26 pm

Re: fuel pump

Post by chris01cobra » Thu May 21, 2015 12:48 pm

Oh yeah it is a returnless system 2001 Mustang Cobra.

User avatar
Sniper Chris
General of the Army
General of the Army
Posts: 574
Joined: Fri Jul 20, 2007 3:54 pm
Location: Sanford, FL
Contact:

Re: fuel pump

Post by Sniper Chris » Fri May 22, 2015 11:09 am

Did you make the base tune with the Special Forces software? If not, try doing that but be sure the answer all the questions accurately. If you did make the base tune with SF, then it would seem that you selected something wrong with the drop down questions. The AF should not have gotten that rich with a SF tune.
Director of Sales & Marketing
Technical Support

407.321.5725
www.DeltaForceTuning.com

chris01cobra
Private
Private
Posts: 4
Joined: Mon Jan 21, 2013 8:26 pm

Re: fuel pump

Post by chris01cobra » Fri May 22, 2015 5:18 pm

Acting so funny it makes me wonder if they sent me the right fuel pump. All the information I put into sniper force is correct. Is there any way that I could tell without dropping the fuel tank again? Thank.

chris01cobra
Private
Private
Posts: 4
Joined: Mon Jan 21, 2013 8:26 pm

Re: fuel pump

Post by chris01cobra » Sun May 24, 2015 8:37 pm

Yeah it was the wrong pump 255lph 98 and under. Thanks for the help.

Post Reply

Return to “1996 - 2004 Mustang and Cobra”